Who qualifies for Breach Insurance coverage?

McAfee SECURE Breach Insurance is available for Level 2-4 merchants, regardless of the merchant's PCI compliance status, provided the merchant account has not already suffered a data compromise.

Subject to its terms, conditions and exclusions, this Policy applies to a data security event occurring, and security event expenses and post event expenses incurred, anywhere in the world.

Have more questions? Submit a request
Powered by Zendesk